use strict;
my $str = 'Mazurka in A minor, Op. 7, No. 2';
my $regex = qr/(Mazurka)(.+), (Op.+)/mp;
my $subst = '$1 $3$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";