import Foundation
let pattern = #"(Mazurka)(.+), (Op.+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"Mazurka in A minor, Op. 7, No. 2"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1 $3$2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)