#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\b([01][0-9]|2[0-3])([0-5][0-9])\b"
Local $sString = "0000" & @CRLF & _
"2359" & @CRLF & _
"1200" & @CRLF & _
"1201" & @CRLF & _
"0059" & @CRLF & _
"" & @CRLF & _
"0090" & @CRLF & _
"2459" & @CRLF & _
"000" & @CRLF & _
"3000" & @CRLF & _
""
Local $sSubst = "\1:\2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)