import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b([01][0-9]|2[0-3])([0-5][0-9])\\b";
final String string = "0000\n"
+ "2359\n"
+ "1200\n"
+ "1201\n"
+ "0059\n\n"
+ "0090\n"
+ "2459\n"
+ "000\n"
+ "3000\n";
final String subst = "\\1:\\2";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}