using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b([01][0-9]|2[0-3])([0-5][0-9])\b";
string substitution = @"\1:\2";
string input = @"0000
2359
1200
1201
0059
0090
2459
000
3000
";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}