import Foundation
let pattern = #"\b([01][0-9]|2[0-3])([0-5][0-9])\b"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
0000
2359
1200
1201
0059
0090
2459
000
3000
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1:\2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)