// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\b([01][0-9]|2[0-3])([0-5][0-9])\b").unwrap();
let string = "0000
2359
1200
1201
0059
0090
2459
000
3000
";
let substitution = "\\1:\\2";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}