# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/.*src\\/(([^\\/]*)(\\/)?)|(\\/)([^\\/]*)/$2\\$5/mg;t' <<< "/dev/project/src/MVC/Models/Access/Auth
/home/user/dev/project/src/MVC/Models/Access/Auth
/any_other_folder/src/MVC/Models/Access/Auth"