// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m).*src\/(([^\/]*)(\/)?)|(\/)([^\/]*)").unwrap();
let string = "/dev/project/src/MVC/Models/Access/Auth
/home/user/dev/project/src/MVC/Models/Access/Auth
/any_other_folder/src/MVC/Models/Access/Auth";
let substitution = "$2\\\\$5";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}