import re
regex = re.compile(r".*src\/(([^\/]*)(\/)?)|(\/)([^\/]*)", flags=re.MULTILINE)
test_str = ("/dev/project/src/MVC/Models/Access/Auth\n\n\n"
"/home/user/dev/project/src/MVC/Models/Access/Auth\n\n\n"
"/any_other_folder/src/MVC/Models/Access/Auth")
subst = "$2\\\\$5"
result = regex.sub(subst, test_str)
if result:
print(result)