use strict;
my $str = '/dev/project/src/MVC/Models/Access/Auth
/home/user/dev/project/src/MVC/Models/Access/Auth
/any_other_folder/src/MVC/Models/Access/Auth';
my $regex = qr/.*src\/(([^\/]*)(\/)?)|(\/)([^\/]*)/mp;
my $subst = '$2\\\\$5';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";