$re = '/.*src\/(([^\/]*)(\/)?)|(\/)([^\/]*)/m';
$str = '/dev/project/src/MVC/Models/Access/Auth
/home/user/dev/project/src/MVC/Models/Access/Auth
/any_other_folder/src/MVC/Models/Access/Auth';
$subst = "$2\\$5";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;