#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m).*src\/(([^\/]*)(\/)?)|(\/)([^\/]*)"
Local $sString = "/dev/project/src/MVC/Models/Access/Auth" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"/home/user/dev/project/src/MVC/Models/Access/Auth" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"/any_other_folder/src/MVC/Models/Access/Auth"
Local $sSubst = "$2\\$5"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)