import Foundation
let pattern = #".*src\/(([^\/]*)(\/)?)|(\/)([^\/]*)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
/dev/project/src/MVC/Models/Access/Auth
/home/user/dev/project/src/MVC/Models/Access/Auth
/any_other_folder/src/MVC/Models/Access/Auth
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$2\\$5"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)