# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(STREET|ST\.)([A-Z]{3,})/\1 \2/gm;t' <<< "1201 WEST FRONT STREETCHESTER PA 19013-3496
703 6TH STREET SOUTHTEXAS CITY TX 77590
"