import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(STREET|ST\\.)([A-Z]{3,})";
final String string = "1201 WEST FRONT STREETCHESTER PA 19013-3496\n"
+ "703 6TH STREET SOUTHTEXAS CITY TX 77590\n";
final String subst = "\\1 \\2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}