// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(STREET|ST\.)([A-Z]{3,})").unwrap();
let string = "1201 WEST FRONT STREETCHESTER PA 19013-3496
703 6TH STREET SOUTHTEXAS CITY TX 77590
";
let substitution = "\\1 \\2";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}