re = /(STREET|ST\.)([A-Z]{3,})/m
str = '1201 WEST FRONT STREETCHESTER PA 19013-3496
703 6TH STREET SOUTHTEXAS CITY TX 77590
'
subst = '\\1 \\2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result