using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(STREET|ST\.)([A-Z]{3,})";
string substitution = @"\1 \2";
string input = @"1201 WEST FRONT STREETCHESTER PA 19013-3496
703 6TH STREET SOUTHTEXAS CITY TX 77590
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}