use strict;
my $str = '1201 WEST FRONT STREETCHESTER PA 19013-3496
703 6TH STREET SOUTHTEXAS CITY TX 77590
';
my $regex = qr/(STREET|ST\.)([A-Z]{3,})/mp;
my $subst = '\\1 \\2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";