#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(STREET|ST\.)([A-Z]{3,})"
Local $sString = "1201 WEST FRONT STREETCHESTER PA 19013-3496" & @CRLF & _
"703 6TH STREET SOUTHTEXAS CITY TX 77590" & @CRLF & _
""
Local $sSubst = "\1 \2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)