import Foundation
let pattern = #"(STREET|ST\.)([A-Z]{3,})"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
1201 WEST FRONT STREETCHESTER PA 19013-3496
703 6TH STREET SOUTHTEXAS CITY TX 77590
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1 \2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)