package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)iPhone|iPod|Android.*Chrome/[.0-9]* Mobile|Mobile.*Firefox`)
var str = `iPhone asd
iPod asd
Android merda Chrome/123 Mobile
Tonino Browser
Mobile asd Firefox/123
Firefox Desktop
Firefox/Desktop
Firefox/asd
Desktop Firefox/123
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}