# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"iPhone|iPod|Android.*Chrome/[.0-9]* Mobile|Mobile.*Firefox"
test_str = ("iPhone asd\n"
"iPod asd\n"
"Android merda Chrome/123 Mobile\n"
"Tonino Browser\n"
"Mobile asd Firefox/123\n"
"Firefox Desktop\n"
"Firefox/Desktop\n"
"Firefox/asd\n"
"Desktop Firefox/123\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.