re = /iPhone|iPod|Android.*Chrome\/[.0-9]* Mobile|Mobile.*Firefox/m
str = 'iPhone asd
iPod asd
Android merda Chrome/123 Mobile
Tonino Browser
Mobile asd Firefox/123
Firefox Desktop
Firefox/Desktop
Firefox/asd
Desktop Firefox/123
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end