// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)iPhone|iPod|Android.*Chrome/[.0-9]* Mobile|Mobile.*Firefox").unwrap();
let string = "iPhone asd
iPod asd
Android merda Chrome/123 Mobile
Tonino Browser
Mobile asd Firefox/123
Firefox Desktop
Firefox/Desktop
Firefox/asd
Desktop Firefox/123
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}