#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(pinterest)"
Local $sString = "pinterest.fr" & @CRLF & _
"pinterest.com" & @CRLF & _
"pinterest.com.mx"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)