const regex = /(pinterest)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(pinterest)', 'g')
const str = `pinterest.fr
pinterest.com
pinterest.com.mx`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);