import re
regex = re.compile(r"(pinterest)")
test_str = ("pinterest.fr\n"
"pinterest.com\n"
"pinterest.com.mx")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)