$re = '/(pinterest)/';
$str = 'pinterest.fr
pinterest.com
pinterest.com.mx';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;