#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)HOWMUCH?*\s*_*\s*(\s*(\d+)\s*)_*\s*USD"
Local $sString = " 1. HOWMUCH?__10_ USD" & @CRLF & _
" 1. HOWMUCH?_20_USD" & @CRLF & _
" 1. HOWMUCH?30__ USD" & @CRLF & _
" 1. HOWMUCH?__40___ USD" & @CRLF & _
" 1. HOWMUCH? 50 USD" & @CRLF & _
" 1. HOWMUCH? __60___USD" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")