$re = '/HOWMUCH?*\s*_*\s*(\s*(\d+)\s*)_*\s*USD/m';
$str = ' 1. HOWMUCH?__10_ USD
1. HOWMUCH?_20_USD
1. HOWMUCH?30__ USD
1. HOWMUCH?__40___ USD
1. HOWMUCH? 50 USD
1. HOWMUCH? __60___USD
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);