re = /HOWMUCH?*\s*_*\s*(\s*(\d+)\s*)_*\s*USD/m
str = ' 1. HOWMUCH?__10_ USD
1. HOWMUCH?_20_USD
1. HOWMUCH?30__ USD
1. HOWMUCH?__40___ USD
1. HOWMUCH? 50 USD
1. HOWMUCH? __60___USD
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end