// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)HOWMUCH?*\s*_*\s*(\s*(\d+)\s*)_*\s*USD").unwrap();
let string = " 1. HOWMUCH?__10_ USD
1. HOWMUCH?_20_USD
1. HOWMUCH?30__ USD
1. HOWMUCH?__40___ USD
1. HOWMUCH? 50 USD
1. HOWMUCH? __60___USD
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}