const regex = /HOWMUCH?*\s*_*\s*(\s*(\d+)\s*)_*\s*USD/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('HOWMUCH?*\\s*_*\\s*(\\s*(\\d+)\\s*)_*\\s*USD', 'gm')
const str = ` 1. HOWMUCH?__10_ USD
1. HOWMUCH?_20_USD
1. HOWMUCH?30__ USD
1. HOWMUCH?__40___ USD
1. HOWMUCH? 50 USD
1. HOWMUCH? __60___USD
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}