import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "HOWMUCH?*\\s*_*\\s*(\\s*(\\d+)\\s*)_*\\s*USD";
final String string = " 1. HOWMUCH?__10_ USD\n"
+ " 1. HOWMUCH?_20_USD\n"
+ " 1. HOWMUCH?30__ USD\n"
+ " 1. HOWMUCH?__40___ USD\n"
+ " 1. HOWMUCH? 50 USD\n"
+ " 1. HOWMUCH? __60___USD\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}