using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"HOWMUCH?*\s*_*\s*(\s*(\d+)\s*)_*\s*USD";
string input = @" 1. HOWMUCH?__10_ USD
1. HOWMUCH?_20_USD
1. HOWMUCH?30__ USD
1. HOWMUCH?__40___ USD
1. HOWMUCH? 50 USD
1. HOWMUCH? __60___USD
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}