import re
regex = re.compile(r"HOWMUCH?*\s*_*\s*(\s*(\d+)\s*)_*\s*USD", flags=re.MULTILINE)
test_str = (" 1. HOWMUCH?__10_ USD\n"
" 1. HOWMUCH?_20_USD\n"
" 1. HOWMUCH?30__ USD\n"
" 1. HOWMUCH?__40___ USD\n"
" 1. HOWMUCH? 50 USD\n"
" 1. HOWMUCH? __60___USD\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")