# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/([[a-z]&&[^aeiou]]+)/p$1/gm;t' <<< "extracto de cafe molido a la piedra"