using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([[a-z]&&[^aeiou]]+)";
string substitution = @"p$1";
string input = @"extracto de cafe molido a la piedra";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}