$re = '/([[a-z]&&[^aeiou]]+)/m';
$str = 'extracto de cafe molido a la piedra';
$subst = "p$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;