#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)([[a-z]&&[^aeiou]]+)"
Local $sString = "extracto de cafe molido a la piedra"
Local $sSubst = "p$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)