re = /([[a-z]&&[^aeiou]]+)/m
str = 'extracto de cafe molido a la piedra'
subst = 'p$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result