// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)([[a-z]&&[^aeiou]]+)").unwrap();
let string = "extracto de cafe molido a la piedra";
let substitution = "p$1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}