import re
regex = re.compile(r"([[a-z]&&[^aeiou]]+)", flags=re.MULTILINE)
test_str = "extracto de cafe molido a la piedra"
subst = "p$1"
result = regex.sub(subst, test_str)
if result:
print(result)