use strict;
my $str = 'extracto de cafe molido a la piedra';
my $regex = qr/([[a-z]&&[^aeiou]]+)/mp;
my $subst = 'p$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";