# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(<div\s+class=["']fw-bold["']\s*>\s*Финансовая отчетность)[^<]+(<\\/div>)/$1$2/;t' <<< "<div class=\"fw-bold\">Финансовая отчетность за 2024 год</div>
"