const regex = /(<div\s+class=["']fw-bold["']\s*>\s*Финансовая отчетность)[^<]+(<\/div>)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(<div\\s+class=["\']fw-bold["\']\\s*>\\s*Финансовая отчетность)[^<]+(<\\\/div>)', '')
const str = `<div class="fw-bold">Финансовая отчетность за 2024 год</div>
`;
const subst = `$1$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);