// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(<div\s+class=["']fw-bold["']\s*>\s*Финансовая отчетность)[^<]+(<\/div>)"#).unwrap();
let string = "<div class=\"fw-bold\">Финансовая отчетность за 2024 год</div>
";
let substitution = "$1$2";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}