using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(<div\s+class=[""']fw-bold[""']\s*>\s*Финансовая отчетность)[^<]+(<\/div>)";
string substitution = @"$1$2";
string input = @"<div class=""fw-bold"">Финансовая отчетность за 2024 год</div>
";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}